EdgeOS 1.9.0 IPv6 and Comcast

August 8, 2016

IPv6 Configuration Page

TL;DR: For Comcast IPv6, use a prefix length of /60.

OK, the IPv6 configuration took a bit longer than expected. There is a new release of EdgeOS for EdgeRouters, version 1.9.0 and it can be found here. What caught my eye was:

When IPv6 PD is enabled on the WAN interface, the prefix length and whether to enable default IPv6 firewall can be configured. The IPv6 LAN interfaces are not configurable currently and are the same as the LAN interfaces for the IPv4 part of the wizard (e.g., in this case two LANs are used so the corresponding interfaces eth1 and eth2 are shown in "IPv6 LANs"). Also note that currently all LAN interfaces will use "service slaac". We may expand the wizard to allow more configuration options for the LAN interfaces in the future.

Ubiquiti finally added basic IPv6 configuration to EdgeOS. I couldn't find where to actually configure it via the GUI -- I know I can do it via the CLI and have done it that way, but it was always finicky. I ended up reconfiguring my EdgeRouter Lite from scratch -- the thing was not heavily customized, so it wasn't bad getting up configured again... Until I was trying to get IPv6 working.

Here's what I did to finally make it work with Comcast (this is configured with WAN on eth0 and LAN on eth1):

Change the other settings for things like LAN1, LAN2 and users to your preferences. Save and reboot. When the EdgeRouter comes back up, you should see a IPv6 /128 address for WAN and IPv6 /64 addresses for LAN1 and LAN2.

Let your computer/device get its addresses via DHCP, then use test-ipv6.com to make sure everything is working fine.


[ Archive ]